A number of payment incidents are ongoing. We are also experiencing a technical problem on our app.

Incident Report for Swile

Resolved

This incident has been resolved
Posted Feb 20, 2023 - 12:12 UTC

Monitoring

Root cause identified, a fix was deployed, we are monitoring
Posted Feb 20, 2023 - 11:30 UTC

Identified

It seems that a number of payment incidents are ongoing. We are also experiencing a technical problem on our app.
Our support teams are currently mobilized in priority to assist affected users. As a result, our response time may be extended. We are doing everything necessary to return the situation to normal as soon as possible.
Posted Feb 20, 2023 - 11:28 UTC
This incident affected: Payment platform and Employee platform.